Tag Archives: problem

BIOS Randomness Disabling My PS/2 Keyboard and Mouse

So, it seems after altering the fan settings on my BIOS I can’t use my keyboard and mouse (this is being posted from my laptop). Do you know how annoying it is to not even have Windows recognise USB ones either? I don’t know why it decided to do this really, I just hope to set my BIOS up in a way so I can actually use USB keyboards to access it so I can get to the BIOS whatever!

So, before I do a BOIS CMOS reset which should fix the problem, I need to make a backup of my fakeRAID0’ed data to an external HDD. I managed to get one drive recognised using DMRAID in Knoppix, but for some reason only the OS parition on the first two drives. The other 2 partitions (over the other 4 HDD’s) were not mountable, and trying the internet for answers didn’t help (It likely is the info for the RAID is not where DMRAID is looking for it but I’ve no idea how to fix that. The OS one was detected since it basically is only on the first 3rd of the RAID0).

Therefore I moved onto BartPE, and after finally realising after one CD that the “Press F6 to choose RAID drivers” in it obviously wouldn’t work…so I made a new CD integrating it (which was pretty easy actually!). Data is copying now, once it’s all on a external HDD I’ll be happier if I have to wipe it.

Must implement that weekly backup routine I intended to do weeks ago…must also get another terabyte external HDD to do this on! Lesson to everyone here is BIOS settings suck to change if they can disable your PS/2 ports (or hopefully I haven’t got broken ones which is the other option, sigh). I don’t know what kind of lesson it is, but it’s a “waste a day getting data off your hard drives in a PE environment” if it’s anything to go by.

Update: I did reset my BIOS, and it did sort my mouse/keyboard (and I’ve now enabled USB ones too). I still am unsure which option changed it, so always beware and backup before changing the BIOS! 🙂